Educamos funciona bien con las últimas versiones de todos los navegadores pero está optimizado para todos los navegadores modernos como Chrome, Firefox o Safari o la última versión de Internet Explorer. Recomendamos usar uno de estos 4 navegadores, que se pueden descargar de forma gratuita en la web, para no tener ningún problema.

Muchos de los fallos más comunes son debido a un uso de un navegador no adecuado.

Educamos (como muchos sitios de cualquier sector desde hace ya más de 5 años) no está optimizado para versiones antiguas de Internet Explorer por lo que un uso del mismo puede provocar errores o fallos.